Bug Encoding UTF-8

  1. ‹ Older
  2. 5 months ago

    I collected more information
    -image-

  3. Chris

    Nov 28 Developer, Moderator, Beta Tester

    Thanks for the information. However, I've just realised that your screenshots use a completely different email message than the ones you sent to me. The ones I received were full of large tables of data.

    Please send me that original email message to chris@bitespire.com from the hosting source. I feel we are close.

  4. Chris

    Nov 28 Developer, Moderator, Beta Tester

    Ah! a Windows Server 2008!

    Is doogiePIM running on the Win2008 machine or the Win10Pro machine?
    Which machine are your other email clients running on?
    Do you have the UTF8 character set installed on your server?

    I really need more information about your setup. If you believe this should be private then send this via email or use the Private Messaging of this forum.

  5. I tested on Windows pro and on server 2008

  6. On two pc problem, I always sent a new letter

  7. I checked the mail template for sending messages, messages are sent to utf-8
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title></title>
    <style type="text/css">
    /* Client-specific Styles */

    #outlook a {padding:0;}
    body{width:100% !important; -webkit-text-size-adjust:100%; -ms-text-size-adjust:100%; margin:0; padding:0;}
    .ExternalClass {width:100%;}
    .ExternalClass,
    .ExternalClass p,
    .ExternalClass span,
    .ExternalClass font,
    .ExternalClass td,
    .ExternalClass div {line-height: 100%;}
    #backgroundTable {margin:0; padding:0; width:100% !important; line-height: 100% !important;}

    /* End reset */
    </style>
    <?
    /*
    This is commented to avoid Project Quality Control warning
    $APPLICATION->ShowHead();
    $APPLICATION->ShowTitle();
    $APPLICATION->ShowPanel();
    */
    ?>
    </head>

  8. I tried many options:
    I installed fully English in UTF-8 format
    I ran doogiePim on server 2008
    I sent letters in different ways
    But nothing helped

  9. Chris

    Nov 29 Developer, Moderator, Beta Tester

    Today I discovered if you make your account as POP3 then the message is received correctly. On my test machine it did.

    Please try as a POP3 and let me know if that helps. In the meantime, I will work on the IMAP4 version. This is quite an odd rare situation that involves the format of certain email servers.

  10. POP3 does not work, writes not known Protocol

  11. I installed IMAP4 registered the server address pop3.beget.com the letters loaded . . .

  12. Encoding error remained ((((((

  13. I recorded a video, look https://yadi.sk/d/Ff_8It_vDiduyA

  14. Chris

    Nov 30 Developer, Moderator, Beta Tester
    Edited 5 months ago by Chris

    Вы используете порт 143. Это неправильно. Это касается только IMAP.
    Если у вас нет SSL, используйте порт 110 для POP3.
    Я также предлагаю вам установить SSL / TLS и использовать порт POP3 995. Это значит, что ваш почтовый транспорт зашифрован.

    You are using port 143. That is wrong. That is only for IMAP.
    If you don't have SSL then use Port 110 for POP3.
    I would also suggest you install SSL/TLS and use POP3 port 995. This is so your email transport is encrypted.

    -image-

  15. -image-
    Work!

  16. Chris

    Nov 30 Developer, Moderator, Beta Tester

    :)

  17. Удалось ли найти проблему?
    Did you find the problem?

  18. Chris

    Dec 8 Developer, Moderator, Beta Tester

    @Voldemar227 Удалось ли найти проблему?
    Did you find the problem?

    Проблема заключается в IMAP4 в сочетании с определенной кодировкой символов Unicode на почтовых серверах вашего типа. POP3 в порядке и работает хорошо. Я бы оставался с POP3, пока не перепишу некоторые подпрограммы IMAP4, чтобы приспособить этот тип архитектуры сервера.

    The problem is with the IMAP4 in combination with certain Unicode character encoding on your type of email servers. POP3 is fine and works well. I would stay with POP3 until I rewrite some of the IMAP4 routines to accommodate this type of server architecture.

  19. Edited 5 months ago by Voldemar227

    С POP3 есть проблемы, программа зависает и закрывается....
    Так же есть письма с ошибками кодировки...

    There are problems with POP3, the program hangs and closes. . . .
    There are also letters with encoding errors. . .

    Я приложил скриншот и письмо
    I have attached a screenshot and a letter
    https://yadi.sk/d/czMwXVYclEQZyQ

  20. Video new bug https://yadi.sk/d/l15AgrzB5RdnQw

  21. Chris

    Dec 11 Developer, Moderator, Beta Tester
    Edited 5 months ago by Chris

    Странная маленькая вещь, но я думаю, что вижу небольшую проблему. Я могу исправить это сегодня и дать патч позже.
    Видео действительно помогло обнаружить ошибку.
    Большое спасибо.

    An odd little thing but I think I see the minor problem. I can fix it today and upload a patch later.
    The video was really helpful in spotting the error.
    Many thanks.

  22. Thanks!

  23. Chris, I managed to catch the message with the wrong encoding in the subject. Now I will register on this resource to your email address chris@bitespire.com. You will receive an information letter, pay attention to the subject of the letter.

    -image-

  24. Chris

    Dec 11 Developer, Moderator, Beta Tester

    Good catch. This gives me more evidence of the problem. Many thanks.

  25. Chris

    Dec 11 Developer, Moderator, Beta Tester

    FYI: it's charset=Windows-1251
    I'm working on fixing this today.

  26. @Chris FYI: it's charset=Windows-1251

    Yes, in Russian localization for Windows this encoding is often used. You can also meet koi8-r.

  27. @Sergiy Yes, in Russian localization for Windows this encoding is often used. You can also meet koi8-r.

    Yes. This is often

  28. Chris

    Dec 11 Developer, Moderator, Beta Tester
    Edited 5 months ago by Chris

    It will take me a few days or two but I'm working on rewriting improving detection on the following encodings:

    Russian (KOI8-R); CodePage:20878; 'x-koi8-r';
    Russian (KOI8)'; CodePage:20866; 'koi8';
    Russian (ISO)'; CodePage:28595; 'iso-8859-5';
    Russian (Windows)'; CodePage:01251; 'windows-1251';

    This should help the display of said characters.

  29. Hello! How is it going ?

  30. Chris

    Dec 14 Developer, Moderator, Beta Tester

    I'm still working on it.

  31. Hello! How is it going ?

  32. Chris

    Dec 19 Developer, Moderator, Beta Tester

    Я собираю тестовую версию полного пакета сегодня днем и выложу ее завтра. Будет новая страница загрузки, которая будет обнародована завтра.

    I'm building a test version complete package this afternoon and will upload it tomorrow. There will be a new download page of which will be made public on the morrow.

  33. 4 months ago

    Chris

    Dec 21 Developer, Moderator, Beta Tester

    I've uploaded a new complete package here: https://bitespire.com/download.php
    There is a new web page for test versions here: https://bitespire.com/doogiepim_testversion.php

  34. @Chris I've uploaded a new complete package here: https://bitespire.com/download.php
    There is a new web page for test versions here: https://bitespire.com/doogiepim_testversion.php

    Thank!
    The problem with imap is still there
    -image-

  35. Chris

    Dec 21 Developer, Moderator, Beta Tester

    IMAP4 is still being worked on but POP3 should be okay. I have a dedicated Russian machine for testing in comparison to Outlook and other various Email clients. I expect IMAP4 protocol libraries to be ready in Jan 2019.

  36. @Chris IMAP4 is still being worked on but POP3 should be okay. I have a dedicated Russian machine for testing in comparison to Outlook and other various Email clients. I expect IMAP4 protocol libraries to be ready in Jan 2019.

    POP3

    -image-

  37. Chris

    Dec 21 Developer, Moderator, Beta Tester
    Edited 4 months ago by Chris

    Thanks. Please send that email (or any other strange looking message) to my test email account:
    bitespire (at) gmail (dot) com
    Don't use doogiePIM to send it, use a different email client.

    It's not enough just for a screenshot. I would need to know the encoding of the message and on what kind of operating system it was received on.

    I really appreciate your help in finally bringing these bugs to the surface where they can be fixed once and for all.

  38. Edited 4 months ago by Chris

    @Chris Thanks. Please send that email (or any other strange looking message) to my test email account:
    Don't use doogiePIM to send it, use a different email client.

    It's not enough just for a screenshot. I would need to know the encoding of the message and on what kind of operating system it was received on.

    I really appreciate your help in finally bringing these bugs to the surface where they can be fixed once and for all.

    I sent 2 letters, a letter in the body and a letter in the attachment

  39. Chris

    Dec 21 Developer, Moderator, Beta Tester

    Received. Many thanks. I'll work on the decoding of it.

  40. I get a lot of mail problems. The program hangs when it opens a letter, the program hangs when I send letters. . . So every second and third time. . .

    Я получаю очень много проблем с почтой. Программа зависает когда открывает письма, программа зависает когда отправляю письма... Так каждый второй -третий раз...

  41. Chris

    Dec 22 Developer, Moderator, Beta Tester

    @Voldemar227 I get a lot of mail problems. The program hangs when it opens a letter, the program hangs when I send letters. . . So every second and third time. . .

    Я получаю очень много проблем с почтой. Программа зависает когда открывает письма, программа зависает когда отправляю письма... Так каждый второй -третий раз...

    Please move this to a new thread with more information such as what kind of message you are trying to send. Does it have large attachments, etc.
    The more I know, the quicker I can fix it.

    If you see doogiePIM not responding when try to send a message, or even try to read a message. This is probably due to large attachments. Simply wait about ten minutes to see if the display returns to normal. You may also experience slow reaction time due to slow Internet upload speeds when trying to send a message. Your Email has to be uploaded so having a speed of 0.3Mbs can really make a difference to the reaction time.

    As I don't know anything about your Internet speed, message type and can only guess you are sending from a Windows 10 PC then I can't help without knowing more.

    Before closing this thread, happy holidays and we'll continue in the new thread.

    Переместите это в новую ветку с дополнительной информацией, например, о том, какое сообщение вы пытаетесь отправить. Есть ли у него большие вложения и т. Д.
    Чем больше я знаю, тем быстрее я могу это исправить.

    Если вы видите, что doogiePIM не отвечает при попытке отправить сообщение или даже попытаться прочитать сообщение. Вероятно, это связано с большими вложениями. Просто подождите около десяти минут, чтобы увидеть, вернется ли дисплей в нормальное состояние. Вы также можете столкнуться с медленным временем реакции из-за низкой скорости загрузки Интернета при попытке отправить сообщение. Ваша электронная почта должна быть загружена таким образом, чтобы скорость 0,3 Мбит действительно могла повлиять на время реакции.

    Поскольку я ничего не знаю о вашей скорости интернета, типе сообщения и могу только догадываться, что вы отправляете с ПК с Windows 10, то я не могу не знать больше.

    Прежде чем закрыть эту тему, счастливых праздников, и мы продолжим в новой теме.

 

or Sign Up to reply!