"DoogiePIM not responding"

  1. 4 months ago

    The advent of version 2.x has brought the appearance of the message "Doogie PIM not responding" at a strikingly high frequency. No session goes by without having to contend with the lack of response. The PIM "freezes". The wait for the PIM to be responsive again varies from 20 seconds to more than two minutes. The lack of responsiveness occurs equally in the two databases that I have created. No clue as to what triggers this behavior.

    The PIM workspace becomes bright white when I click in the text or use the spacebar and the screen freezes. I can switch to other programs that are open at the time and continue work in them. The computer does not freeze: DoogiePIM does. The message "DoogiePIM not responding" appears only when I click again onto the "frozen" document. The window offers two possible actions: close the program or wait until DoogiePIM responds. I always choose the latter because I don't want to lose the data that I just entered and may not have been saved yet.

    Are other users experiencing this? What is the cause? I have stopped using DoogiePIM at present because I am experiencing three problems simultaneously as reported elsewhere in this blog. hoping for solutions soon.

  2. Chris

    Oct 25 Developer, Moderator, Beta Tester

    What is your hardware configuration?
    What is the filesize of your database?

  3. Edited 4 months ago by RandallG

    I've not ever experienced this nor have I read anyone else experiencing this. I wonder if you have run an anti-virus and malware scan recently? Also are you insuring that the scanning software is up to date and has current virus definition files? I'd start there for sure. Also, you should respond to Chris' request for info. He's always here to help. I'm curious what version of Windows are you using and is it also up to date with Windows updates?

  4. Chris

    Oct 26 Developer, Moderator, Beta Tester
    Edited 4 months ago by Chris

    Replied here:
    https://bitespire.com/community/conversation/post/1157

  5. I have been experiencing the same problem, but it occurs when I try to send an email that I have replied to. Not every time but about 80% of the time. Not occurring in other modules.

  6. I just tried something that helped my situation. In the "Messages" settings both boxes were unchecked for "Delete Attachments" before Reply and Forward. I checked the delete Reply and my message was sent.

  7. Chris

    Oct 31 Developer, Moderator, Beta Tester

    @Gayle
    Ah! (lightbulb above head moment)
    I feel there are kinds of binary attachments that are taking too long or are too hard to encode. I suspect that's the problem. I'll work on that and try and get a fix in for the next release.

    Many thanks for your input.

  8. 6 weeks ago

    Please help. My doogiePIM has stopped responding. I open the database and open the calendar. As soon as I double-click on an event (I want to edit the event), the program refuses to respond to anything I try to do. I cannot open another tab, open an event, open a task, highlight a different icon, etc. However, task reminders will still pop-up. The Task Reminder window DOES respond. If I click on Locate, the program does respond by opening the task tab and locating the specific task. When I click on Open, the task will open. I can make changes on the Task pop-up window. Once I return to the main program, I cannot select anything. I get no response. If I continue to click, I start getting error sounds, like I've selected an invalid option.
    I am on the Jan 22 version of the program. I'm running Windows 10. I use eset for anti-virus and Malwarebytes for anti-malware.
    Thanks.

  9. I wanted to add my two cents. I have the same problem occur. I get a pop-up that says Oops something happened. I get a choice to close Doogie or keep using it. This has been happening a lot in Messaging. I haven't used the other modules yet. I am glad others brought this up. It was hard to isolate what was going on because I wasn't doing anything out of the ordinary and I didn't know how to isolate the problem. Chris I also wanted to bring your attention that when I tried to export messages I still can't do many. I can only do one at a time. I know you said you fixed it so I am not sure if I am doing something wrong. The other issue with messaging is most of the graphics show up but some still don't. I am not sure if you can do a little more to take care of that. For example, I get periodic emails from Kohls. I know they are very graphical but I can't see anything in the email at all. Other email programs seem to have no problem with the pictures. Thanks.

  10. Chris

    Feb 5 Developer, Moderator, Beta Tester

    @LeMayzing Please help. My doogiePIM has stopped responding. I open the database and open the calendar. As soon as I double-click on an event (I want to edit the event), the program refuses to respond to anything I try to do..

    You'll be pleased to know, there's nothing wrong with your data or operation. You've experienced what is known as a Modal Window. The Calendar Event window, when opened, waits for you to Save or Cancel your edit before doing anything else on the main window. This is the same as opening the Settings. If you attempt to click elsewhere on doogiePIM other than the Event window, you'll hear a beep. Simply finish the edit on the Event and your Calendar session can resume.

    @scooterg I wanted to add my two cents. I have the same problem occur. I get a pop-up that says Oops something happened. I get a choice to close Doogie or keep using it. This has been happening a lot in Messaging

    When you get this message, something is wrong. You should send me the DevReport that is generated so I can fix that problem. The Dev Report breaks down exactly where the glitch happened. It's the most useful thing for me to quickly identify and fix a bug.

    @scooterg Chris I also wanted to bring your attention that when I tried to export messages I still can't do many. I can only do one at a time. I know you said you fixed it so I am not sure if I am doing something wrong.

    You're not doing anything wrong. It's my fault. I only fixed export using the command [File/Export/Mail Message...] I now realise I need to fix the Import/Export dialog too. I'll get that fixed for today's release.

    @scooterg The other issue with messaging is most of the graphics show up but some still don't. I am not sure if you can do a little more to take care of that. For example, I get periodic emails from Kohls. I know they are very graphical but I can't see anything in the email at all. Other email programs seem to have no problem with the pictures.

    Most other Email clients use a web browser to display email content, which can lead to security problems. doogiePIM uses its own HTML rendering engine so no known problems with security. However, it means some email content won't look exactly the same as when viewed in a web browser. But, the point of email is to read messages not to go surfing, so a small trade off seemed to be acceptable. Images delivered by some emails, especially sent from those who wish you to buy things, tend to use a lot of styling with large images and effects. It's possible the missing images are images other than normal BMP, PNG, JPG or GIF. I would love to see a sample. If you could tell me the source sender URL of the email you are receiving, I can subscribe to them and see for myself the content construction and see if I can improve the rendering.

  11. @ Chris
    I understand your explanation of "modality" but this issue is not that. The pop-up windows respond to my mouse clicks. When just the main screen is open, I'm usually on the calendar most often, I cannot do anything. The window locks up. It does not even give me a message. There is no other doogiePIM window/pop-up open (or if there is, it is invisible!!).
    Thanks,
    Bonnie

  12. Chris

    Feb 5 Developer, Moderator, Beta Tester

    @LeMayzing ... I'm usually on the calendar most often, I cannot do anything. The window locks up. It does not even give me a message. There is no other doogiePIM window/pop-up open (or if there is, it is invisible!!).

    Try this:

    1. Restart doogiePIM.
    2. Go to the Calendar and double-click on a time slot. This would bring up an Event screen.

    If you don't see the Event screen, then yes, it's probably off-screen. If this is the case, then do this:
    3.a. Press [Alt+Space]. This should bring up a small menu with some options.
    3.b. Choose [Move] from the small menu.
    3.c. Now press the cursor keys and the hidden off-screen window should appear.

    If you do see the Event window and the Calendar is unresponsive, then refer to my previous answer.

    I'm not sure what else to suggest. If you try to click the Calendar and your PC beeps then there is an open window somewhere that is demanding attention.

    You could try right-clicking on the doogiePIM system try icon (next to the system time). If you get that menu then that proves doogiePIM is still running and not locked up.

    I hope these brainstorms help in some way.

    Chris.

  13. @Chris
    I finally got doogiePIM working again! The hidden screen showed when I used [Alt+Tab] and could see mini windows of all my active windows so that I could choose one. It still would not allow me to select the hidden window. I then tried your steps 3. a, b, and c and that brought the hidden window back into focus. I could then move it and update it. After getting the Event window unstuck, all is well again!!

    Thank you.
    Bonnie

  14. Chris

    Feb 7 Developer, Moderator, Beta Tester

    @LeMayzing : Thanks for sharing the great news.

    -image-

 

or Sign Up to reply!