[Solved] Import EML Files Crashes

  1. 4 years ago


    31 Dec 2018 Test Pilot

    Hi Chris,
    I sent some emails to you on problems importing eml files. One had the information containing the error. Here is what happens. I go to messaging. I select Import from the File menu. I select eml file. I am able to import more than one file. I am able to import 5 messages. I tried doing it with 10 messages and Doogie crashes. Anything more than 10 eml files I sometimes get the error I sent you and other times Doogie completely closes or crashes. I remember was able to do 500 eml files at a time with no problem but now, there is no way. I tried the Import Export Data. I selected eml file. I can only import one file at a time. I would be here for quite a while importing my eml files. Can you please look into this?

  2. Chris

    31 Dec 2018 Developer, Moderator, Test Pilot

    Thanks, I've got your emails. I have your doogiePIM version but I don't know what kind of EML files they are.
    Do any of the "crashing" EML files contain very large attachments?

    The file storage you are loading from, is it a USB drive that switches off automatically or is it a fixed storage?

    Also, try switching off any automatic email check, just in case there's a process conflict.

    I'm "unofficially" on new year holiday at the moment taking a break but I will look further into this for you.

  3. scooterg

    31 Dec 2018 Test Pilot

    The eml files came from a program called Essential PIM. I am pretty sure I don't have many large attachments. I don't get very many attachments anyway. When I exported the eml files, I didn't check attachments. I will look into it further. The drive is fixed storage. It is an SSD drive. I turned many of my power options off including turning off the hard drive so that is not an issue. I will turn off the automatic check in Doogie for now. I understand it is an unofficial holiday. I work for myself and sometimes for me the holiday is if I decide I need time off. I get it. When you work for yourself, it is a different story. I will do some stuff on my end and post back here if I find anything that may shed some light on this.

  4. scooterg

    1 Jan 2019 Test Pilot

    Hi Chris,
    Happy New Year! I sent you an email. I removed all of the attachments and large email files I had. I tried importing 500, 55 and 20 emails. They all failed. I think the problem is with Doogie. I think the import feature needs to be more robust. Thanks.

  5. Chris

    1 Jan 2019 Developer, Moderator, Test Pilot

    A very happy new year to you too.

    I'm happy to say that the problem is found. The glitch is due to the actual filename of the EML files. I'm currently working on fixing this for a new patch.

    When the filenames are simple ANSI characters then EML files import very nicely. However, when there's a special Unicode character in the mix then that tends to put a halt to the whole import.

  6. scooterg

    1 Jan 2019 Test Pilot

    Hi Chris,

    Glad you found the problem! Looking forward to the update. Thanks.

  7. Chris

    2 Jan 2019 Developer, Moderator, Test Pilot

    After testing an import of 833 Google junk EML files in one go into the new version, I can say it appears to be running without crashing.

    It is advised to only import a block of 500 files at a time though.

    I'm planning to include this fix in the 20th January 2019 release. However, you are free to download the patch and try it for yourself.

    The version executable can be downloaded from here: https://bitespire.com/bta/doogiePIM.exe
    This should be copied over to your doogiePIM installtion, overwriting the old executable.

  8. scooterg

    2 Jan 2019 Test Pilot

    Thanks Chris. I will give it a try. I was only thinking of doing about 500 at a time. I appreciate you fixing the problem.

  9. scooterg

    2 Jan 2019 Test Pilot

    I had installed the portable version so I guess I will have to install the installed version.

  10. Chris

    2 Jan 2019 Developer, Moderator, Test Pilot

    It doesn't matter if it's the installation version or the portable. Just copy the new doogiePIM.exe over the old one wherever the application folder is.

  11. scooterg

    3 Jan 2019 Test Pilot

    Sorry Chris. I accidentally removed an extensions pak file out of the folder because I was getting an error CE F3 binaries missing. Was able to put the file back and now everything works as expected. Imported and average of between 500 - 700 messages for a total of over 3,000 messages so it is working well. Thanks again Chris.


or Sign Up to reply!